PROBLEM
Smarthost Servers
ENVIRONMENT
- On-Premise Server + WebMail Installations: Version 6.0 > Current Version
- Webmail Only Installations: Version 6.0 > Current Version
CAUSE
Rerouting required for specific servers
RESOLUTION
Messages to 'non' local accounts will be routed via the remote_smtp router in the Exim configure file /usr/local/atmail/mailserver/configure.The default rule can be modified to relay all outgoing messages via another SMTP-server ( rather then the localhost ) . This is handy for relaying messages to a remote SMTP server for processing, for example a dedicated Antivirus or Anti-Spam appliance/server.
To enable edit the Exim configure file and replace:
dnslookup: driver = dnslookup domains = ! +local_domains transport = remote_smtp ignore_target_hosts = 0.0.0.0 : 127.0.0.0/8 no_more |
With the following:
# This router routes addresses that are not in local domains by doing a DNS # lookup on the domain name. divertnonlocal: driver = manualroute domains = ! +local_domains transport = remote_smtp route_list = * smtp.domain.com ignore_target_hosts = 0.0.0.0 : 127.0.0.0/8 no_more |
Where smtp.domain.com is the name of your external smtp server. The IP address of the Atmail server must have relay-access via the external SMTP server to send outgoing messages.
Save changes and restart Atmail.
/etc/init .d /atmailserver restart |
Can I substitute the route_list = * smtp.domain.com with an IP address? I have Barracuda Email Security Scanner box that I want to divert all outgoing email to. Please advise. Thanks.