help centre
For more info visit status.atmail.com

How can we help?


Search our knowledge base for answers to
common questions and latest updates.



My activities New request

Follow

Upgrading to SpamAssassin 3.3.x

Stewart -

PROBLEM
I want to upgrade my Atmail SpamAssassin installation to the newer version of SpamAssassin.

ENVIRONMENT

  • On-Premise Server + WebMail Installations: Version 6.0 > Current Version

CAUSE
The newer version of SpamAssassin contains many upgrades - up to, and including DKIM checks, an improved SQL settings implementation. You may want to upgrade to this version.

Upgrading is easy; just go through the following steps

RESOLUTION

  1. Download SpamAssassin from:
    http://spamassassin.apache.org/downloads.cgi
    wget "http://apache.mirror.aussiehq.net.au//spamassassin/source/Mail-SpamAssassin-3.3.1.tar.gz"
  2. Extract
    tar xvfz Mail-SpamAssassin-3.3.1.tar.gz -C /usr/local/atmail/server_source/
    cd /usr/local/atmail/server_source/Mail-SpamAssassin-3.3.1
  3. Rename your previous SpamAssassin directory.
    mv /usr/local/atmail/spamassassin /usr/local/atmail/spamassassin.3.2
  4. Install the NetAddr::IP module.
    perl -MCPAN -e 'install NetAddr::IP'
  5. Install.
    perl Makefile.PL  PREFIX=/usr/local/atmail/spamassassin/  && make && make install
  6. Move the local.cf and sqlsettings.cf files.
    cp /usr/local/atmail/spamassassin.3.2/etc/sqlsettings.cf
    /usr/local/atmail/spamassassin.3.2/etc/local.cf
    /usr/local/atmail/spamassassin/etc/mail/spamassassin/
  7. Restart services.
    /etc/init.d/atmailserver restart
  8. Congratulations. Now you have SpamAssassin 3.3.x. Credits to the Apache Software Foundation (http://www.apache.org/) for making a tremendously amazing piece of software.
Have more questions? Submit a request

Comments


Contact our support team


+61 (7) 5357 6605       support@atmail.com