PROBLEM
How can I set up password recovery?
ENVIRONMENT
- atmail suite
- atmail mail server
CAUSE
Allow users to define a recovery email for password reset.
RESOLUTION
Create user for Password Recovery
- From your webadmin, create a user in your Account Manager. Since we are creating a specific user for password recovery, it is appropriate to create the user as 'noreply@domain.com' or something similar. For this example I am using:
- Username: noreply@fish.local
- Domain: fish.local
- Password: Snpg3h#o
Update atmail API.
- Once the account is created, open your api.conf with your favored text editor.
[root@mydomain ~]# vim /etc/atmail/api/api.conf
- Update the following variables to correspond to our newly created noreply user.
###
### Forgot Password
###
FORGOTTEN_PW_USER=noreply@fish.local
FORGOTTEN_PW_PASS=Snpg3h#o - Restart and check the status of your API server.
[root@mydomain ~]# systemctl restart apiserver
[root@mydomain ~]# systemctl status apiserver
● apiserver.service - atmail-api - jmap api for atmail webmail
Loaded: loaded (/usr/lib/systemd/system/apiserver.service; enabled; vendor preset: disabled)
Drop-In: /etc/systemd/system/apiserver.service.d
└─depends.conf
Active: active (running) since Fri 2017-08-25 11:51:33 AEST; 2s ago
Docs: http://www.atmail.com/
Process: 2350 ExecStop=/bin/kill -s QUIT $MAINPID (code=exited, status=0/SUCCESS)
Main PID: 2353 (apiserver)
CGroup: /system.slice/apiserver.service
└─2353 /usr/bin/apiserver -config /etc/atmail/api/api.conf
Aug 25 11:51:33 mydomain.party systemd[1]: apiserver.service: main process exited, code=exited, sta...MENT
Aug 25 11:51:33 mydomain.party systemd[1]: Unit apiserver.service entered failed state.
Aug 25 11:51:33 mydomain.party systemd[1]: apiserver.service failed.
Aug 25 11:51:33 mydomain.party systemd[1]: Started atmail-api - jmap api for atmail webmail.
Aug 25 11:51:33 mydomain.party systemd[1]: Starting atmail-api - jmap api for atmail webmail...
Hint: Some lines were ellipsized, use -l to show in full.
User Testing
- Login to your user account and find settings
-> Accounts.
- Answer a minimum of three security questions.
- Designate a Recovery email address.
- Log-out and test.
- Confirm receipt of recovery email.
Troubleshooting
If you face any issues implementing this feature, the following logs will provide useful information as to why it may be failing.
/var/log/atmail/api.log
/var/log/maillog
Comments